Linux基础介绍【第八篇】,linux基础第八篇

 新葡亰计算机网络     |      2019-12-15

澳门新葡亰网站注册,记一次Multicast DNS(mdns)的问题-(linux 下ifconfig),mdnsifconfig

前言:近期在查询mdns的问题过程一波三折,问题总结下来可以分为三块,都是比较基础性的问题:

澳门新葡亰网站正规吗,1.网关ifconfig查询地址

2.多个程序同时占用一个端口号占用编码问题

3.mdns协议及实现源码

mdns是用于局域网发现的一种协议,网关搭载的linux系统,首先得确定其使用的是哪个地址作为通讯,说一个最简单的指令:ifconfig,虽然早就知道这个指令,但是其实这个指令包含比较多的基础知识。

用我使用的openwrt路由器输入ifconfig:

br-lan    Link encap:Ethernet  HWaddr 04:A1:51:9A:03:67  
          inet addr:198.100.100.1  Bcast:198.100.100.255  Mask:255.255.255.0
          inet6 addr: fdbb:e076:9029::1/60 Scope:Global
          inet6 addr: fe80::6a1:51ff:fe9a:367/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:37358673 errors:0 dropped:0 overruns:0 frame:0
          TX packets:49805372 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:10001210378 (9.3 GiB)  TX bytes:49536338006 (46.1 GiB)

eth0      Link encap:Ethernet  HWaddr BE:7F:7D:5D:09:D9  
          inet6 addr: fe80::bc7f:7dff:fe5d:9d9/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:71274265 errors:0 dropped:0 overruns:383 frame:0
          TX packets:67972711 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:23375869 (22.2 MiB)  TX bytes:4047624223 (3.7 GiB)
          Interrupt:4 

eth0.1    Link encap:Ethernet  HWaddr BE:7F:7D:5D:09:D9  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:27485423 errors:0 dropped:0 overruns:0 frame:0
          TX packets:32246955 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:8388027931 (7.8 GiB)  TX bytes:32142311436 (29.9 GiB)

eth0.2    Link encap:Ethernet  HWaddr 04:A1:51:9A:03:68  
          inet addr:193.168.1.125  Bcast:193.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::6a1:51ff:fe9a:368/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:43788842 errors:0 dropped:0 overruns:0 frame:0
          TX packets:35727507 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:46186987470 (43.0 GiB)  TX bytes:10288278423 (9.5 GiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:10489 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10489 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1066479 (1.0 MiB)  TX bytes:1066479 (1.0 MiB)

wlan0     Link encap:Ethernet  HWaddr 04:A1:51:9A:03:67  
          inet6 addr: fe80::6a1:51ff:fe9a:367/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4839004 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5852922 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:670518236 (639.4 MiB)  TX bytes:1589348208 (1.4 GiB)

wlan1     Link encap:Ethernet  HWaddr 04:A1:51:9A:03:69  
          inet6 addr: fe80::6a1:51ff:fe9a:369/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5443036 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9474688 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1115674576 (1.0 GiB)  TX bytes:1268032438 (1.1 GiB)

此处br-lan,eth0,eth0.1…代表的是什么意思呢?

通过查阅,知道了其实在系统文件(network ,wireless)中针对有线和无线早有配置。

[email protected]:/etc/config# cat network 

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdbb:e076:9029::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option macaddr '04:a1:51:9a:03:67'
        option ipaddr '198.100.100.1'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option macaddr '04:a1:51:9a:03:68'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 1 2 3 4'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 5'

[email protected]:/etc/config# cat wireless 

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/ar934x_wmac'
        option htmode 'HT20'
        option txpower '22'
        option country 'US'
        option channel '6'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option htmode 'HT20'
        option txpower '14'
        option country 'US'

config wifi-iface
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'jthlw-cj5G'
        option encryption 'psk-mixed'
        option key '11223344'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option network 'lan'
        option ssid 'jthlw-cj'
        option encryption 'psk-mixed'
        option key 'cjcjcj12345'

首先粘贴一张盗版的openwrt的架构:

澳门新葡亰网站正规吗 1

网关的两个网卡:eth0,eht2分别为一个有线一个无线网卡,这是两个真实的网卡,是有对应的mac地址的。

通过配置

config interface 'lan'

       option ifname 'eth0.1'

       option force_link '1'

       option type 'bridge'

       option proto 'static'

       option netmask '255.255.255.0'

       option ip6assign '60'

       option macaddr '04:a1:51:9a:03:67'

       option ipaddr '198.100.100.1'



config interface 'wan'

       option ifname 'eth0.2'

       option proto 'dhcp'

       option macaddr '04:a1:51:9a:03:68'

可以看出:eth0是有线网卡,eth0.1,eth0.2从上面通过switch虚拟出来,eth0.1对应LAN口,eth0.2对应WAN口,其地址都可以手动修改。

而radio0, radio1对应的是无线网卡(2.4G ,5G)

而br-lan是虚拟出来的,用于统一管理LAN

[email protected]:/etc/config# brctl show
bridge name     bridge id               STP enabled     interfaces
br-lan          7fff.04a1519a0367       no              eth0.1
                                                        wlan1
                                                        wlan0

所以可以看出,eth0.2用于WAN口,其上一级的IP为:193.168.1.125;eth0.1用于管理LAN口,子LAN口的IP都由198.100.100.1进行分配。

(以上只是自己对网关很浅的一些认识,更多的可以关注下面引用的博客,并且诸如防火墙(firewall的设置可以参见:、etc/config 下面的firewall文件)))

DNS(mdns)的问题-(linux 下ifconfig),mdnsifconfig 前言: 近期在查询mdns的问题过程一波三折,问题总结下来可以分为三块,都是比较...

Linux网络基础

DNS

DNS(Domain Name System)

oldboy.me>>>1.1.1.1过程就需要DNS解析(电脑里配置的DNS)

DNS能干什么?

A记录:oldboy.me>>>1.1.1.1

CNAME:常被CDN服务商应用

MX解析记录:[email protected]搭建邮件服务

PTR反向解析:1.1.1.1>>>邮件服务

A记录解析过程:

浏览器>>> oldboy.me>>>网站服务器的ip地址1.1.1.1>>>ip地址对应的网站服务器

DNS解析流程原理

澳门新葡亰网站正规吗 2

递归查询>>>迭代查询

DNS本身是倒挂的树状结构,它的顶点也是根"."。

澳门新葡亰网站正规吗 3

根服务器,全球13台服务器。

顶级域名:org、com、net、me、cc

一级域名:oldboy、baidu、sina

抓包工具

tcpdump

tcpdump -n icmp -i eth0

nmap

windows:wireshark,sniffer,科来网络分析。

Linux网络基础 网线 568A 568B 线序:橙白橙 绿白蓝 蓝白绿 棕白棕 交换机、路由器 交换机:DLINK、...

Linux基础介绍【第八篇】,linux基础第八篇

澳门新葡亰网站正规吗 4

DNS域名解析查询

dig www.baidu.com

查看dns解析流程

[email protected] www.baidu.com +trace

nslookup

host www.baidu.com

ping www.baidu.com

网络检查

1、ping www.baidu.com ,icmp协议,linux禁止icmp。(高速公路有没有修通)

2、traceroute www.baidu.com -n(跟踪路由)基础检查,各个高速节点有没有修通

windows跟踪路由

tracert –d www.baidu.com

3、telnet www.baidu.com 80检查服务器web有没有开启,服务有没有启动,以及防火墙有没有挡住。

nmap 10.0.0.25 -p 80

nc

不通:

1、80服务没开或端口不存在。

2、fw防火墙阻挡了。

3、服务监听的端口不在连接的ip上。

4、ISP运营商默认不开,申请开端口。

配置默认网关

第一生效文件

第二生效文件

查看网关

删除、添加默认网关

配置与查看网络信息

ifconfig查看配置别名ip等

别名IP,VIP虚拟IP

ifconfig eth0:x down 停掉别名ip。

ip的方式配多个ip,辅助ip。

辅助ip形式:keepalived 高可用一直都是用辅助ip

网卡重启别名ip失效,写成配置文件(/etc/sysconfig/network-scripts/ifcfg-eth0:1)。

lsof

已知一个端口为333,如何查看端口对应的服务名?

方法一:

方法二:

查看删除的但仍被进程占用的文件